Introduction

This user guide describes LongoMatch version 0.14 and later.

LongoMatch is a free sports video analysis software to help coaches in making games analysis.

With LongoMatch you can tag the most important plays of the game and group them by categories to study each detail of the game strategy. Once you tagged a play, you can review it with a simple click, even in slow motion, and adjust the lead and lag time of each play frame by frame using the timeline.

LongoMatch has support for playlists, an easy way to create presentations with plays from different games. If you prefer, you can even export the playlist to a new video.

The most important features of LongoMatch are listed below:

  • Tag plays in different categories
  • One-click review
  • Slow motion review
  • Adjust the lead and lag time for each play
  • Annotations
  • Customizable projects using templates
  • Templates editor
  • Projects manager
  • Timeline
  • Playlist support
  • Video editor
  • Export projects to CVS
  • Support for the most common video formats

Understanding LongoMatch

Projects and Database

LongoMatch understands a game analysis like a Project. For each game you will need to create a new Project, that is stored in the program’s database.

A Project contains the following elements:

  • A set of properties that describes the match (teams’ names, final result and date)
  • A project template (sets the properties of each category)
  • A filename that points to video file containing the recorded game

It’s important to know that you cannot create two Projects for the same video file.

The file’s name is used to set the project’s name, so try to use a filename as descriptive as you can.

Project Templates

LongoMatch lets you tag plays in 20 categories. For each category you can set the following properties:

  • A name that describes the category
  • A lead time
  • A stop time
  • A colour to easily identify the category
  • The visibility of this category (lets you choose if you want to use it or not)

Each Project has a template that contains the properties of the 20 categories, which lets you customize a project just by editing its template.

When you create a new project you have to select a template to load, that can be the default template or a pre-maded one.

Once this template is loaded into the Project you can edit it to customize the Project depending on the needs of the analysis.

Projects Management

Create a new Project

To create a new project go to File->New Project. This shows a dialog to set-up the project’s properties.

_images/new_project.png

Local Team: Name of the local team

Visitor Team: Name of the visitor team

Local Goals: Number of goals scored by the local team

Visitor Goals: Number of goals scored by the local team

Date: Date when the game took place (Does not work on Windows)

Template: Project template used for this project. Select a template from the available ones and edit it, if you need to

File: Video file used for this project

Open a Project

To show the “Open Project” dialog go to File->Open Project. This dialog contains a list with all the projects stored in the database.

_images/open_project.png

To open a project, select one of them and click “Accept”, or double-click in the project you want to open.

Projects Manager

The Projects Manager is used to edit or delete projects. You can open it through “Tools->Projects Manager”

_images/projects_manager.png

You can edit a project by selecting it using the projects’ list in the left side of the screen.

The project is then loaded in the editor. Once you finished with the edition, you can save the changes using the “Save” button.

If you want to remove a project, select the project and click the “Delete” button.

Templates Editor

The templates editor lets you create, edit and delete project templates. To open the Templates Editor dialog go to Tools->Templates Editor. To load a template into the editor, select one from the list.

_images/templates_editor.png

New button: Create a new template

Save button: Save the opened template

Delete button: Delete the opened template

Graphical User Interface Widgets

Main window

After starting LongoMatch, the main window is displayed. This window lets you access to main functionalities, like creating a project, opening a stored one, opening the templates editor, etc...

_images/principal.png

Main window with an opened project

Once you open a project, the main window displays all the widgets that lets you make the analysis. There are two kind of views:

  • Capture view: Used to tag plays
  • Analysis view: Used to adjust plays boundaries

Capture View

To enable the capture view go to “view->Capture Mode”

_images/code_mode.png

Analysis Mode

To enable the analysis view go to “view->Capture Mode”

_images/analysis_mode.png

Multimedia player

The multimedia player displays the video and lets you control the state and position of the stream.

You can toggle between play and pause by clicking the Play/Pause button or by clicking the in the widget with the mouse.

You can change the stream’s position using the time scale. If you prefer, you can use “X” and “Y” keys to do frame stepping.

When a play is loaded into the media player, the “Close Play” button is displayed. Click this button to unload the play and view the full video.

You can change the play rate of the stream using the play rate scale.

The “Prev Play” button lets you go back to the start of a play. If you are viewing a playlist the “Prev Play” and “Next Play” button are used to jump to the previous/next play.

You can change the volume using the “Volume” button.

_images/media_player.png

Plays tagging widget

This widget is used to tag plays in different categories. You can only tag a play in a category if this category is set as “visible” in the project template.

_images/tag_buttons.png

Plays list widget

This widget shows a list with all the tagged plays grouped by categories.

_images/plays_list.png

Timeline widget

The timeline widget represent all the plays in a time line, and lets you edit them.

You can change the time line zoom using the zoom scale.

To position the time line to the current stream position click the “Auto Position” button.

_images/timeline.png

Coding and Analysis

Tag a play

You can tag a play in two ways:

  • Clicking one of the 20 available buttons
  • Right click in the timeline at the desired position and select “Add new play”

The start time of the play is calculated in this way: current_time - section_lead_time.

The stop time of the play is calculated in this way: current_time - section_lag_time.

The current_time is the actual position of the video stream when you use the buttons to tag a play and the cursor’s position in the timeline when you use the timeline to tag a play.

Select View->Capture Mode to show the tagging buttons.

Select View->Analysis Mode to switch to the timeline.

Edit a play

Edit the play’s name

To change the name of a play click in the name’s play using the plays’ list.

Adjust the start and stop time of a play

To change the start and stop time of a play, go to the timeline and click in the borders of the rectangle defining a certain play. Drag the borders to desired position.

Review a play

To review a certain play you may chose one of the following options:

  • Clicking in the plays’row using the plays list widget
  • Clicking in the rectangle defined by this play in the timeline

Delete a play

To delete a play you may choose one of the following options:

  • Right-click in the play’s row using the plays list widget, and select “Delete Play”
  • Right-click in the rectangle defined by this play in the timeline, and select “Delete Play->Play Name”

Presentation tools

Playlists

Playlists are used to group plays from one or various projects, to replay them in the easiest way. To show the playlists widget go to “View->Playlists”. Remember that you have to load a playlist by creating a new one or opening an already saved playlist before trying to add any element. If you want to play a playlist you have to close the opened project, if any.

_images/playlist.png

Create a playlist

To create a playlist click the “New” button in the playlists widget. You will be prompted for filename to store the playlist.

Load a playlist

To load a playlist click the “open” button and select the playlist to load.

Edit a playlist

You can add a play to the playlist right clicking in the play’s row using the plays list widget and selecting “Add to playlist”. To remove a play from the playlist right click on the play and select “Delete”. If you want to change the play order, drag and drop the plays to the desired position. To add plays from different projects to the same playlist, close the actual project and open the project you’d like to add a play from. Remember to save the playlist after editing it.

Export a playlist to a video file

If you prefer you can export the playlist to a video file. The video editor will cut all the segments from the original(s) video(s) and merge them into a new video file. Load a playlist in the playlist widget and click the “Rec” button.

_images/export_to_video.png

Click the “Save” button and choose the filename for the new video file. Select the video quality and click “Record” to start. You will see a progress bar indicating the actual state of the export process.

Export a play as an images series

You can export a play to PGN images right-clicking on a play and selecting “Export to PGN images”.

_images/export_to_png.png

Play: The actual play to export.

Series Name: Name of the images series used to set-up the folder’s name where the images are exported to (My Documents\LongoMatch\snapshots\Series Name\series name-XYZ.png).

Interval: Frames per second to extract. A 5 frames/second interval in a 10 seconds plays will output 50 images, 5 per second.

Projects reports

You can export a whole project into a CSV file to make game statistics with a spreadsheet editor (like OpenOffice Calc or Microsoft Excel). Open a project and go to “Tools->Export to CSV”. You will be prompted for the output filename.